Help Center

Follow

How to install old versions of the Zinio iOS App

Zinio only supports the latest version of their iOS Zinio App.

When going to the App store and trying to install the latest version, if the device is not compatible a pop up message will appear asking if you wish to download the latest compatible version. Please contact Apple or see their support article for further information.  https://support.apple.com/en-us/HT201377

Apart from this exception Apple restrict developers from making old versions of their app available to customers, this means that unfortunately we can not send you a old version to download.

 

Have more questions? Submit a request
Powered by Zendesk